Streaming from OpenWebIf to ProgDVB

#1
Let's continue here the discussion started in the SAT2IP thread as this is a different topic.

The question would be: can you do something in order to play all streams like the VLC does? It could be a problem in PMT as you say but why others can play that stream and ProgDVB cannot?
| WinXP SP3 or Win10 1709 | i5 660@3.33Ghz | 4 Gb RAM | ATI Radeon HD 5450 1Gb|
| TT S2-3200 | TT 1501| Astrometa| TT Infrared Receiver| Octagon SF4008 for streaming to ProgDVB|
| Prog demux |
| VMR7 | CyberlinK video decoder (MPEG2) and FFDShow for H264 - DXVA enabled |
| ProgAR | FFDShow audio | Audio processor enabled |
| Timeshift in RAM | Buffer size 2000 |

Re: Streaming from OpenWebIf to ProgDVB

#3
I updated to the latest version of ProgDVB and this problem seem to have been solved. It finally works well! I can stream all the channels I want from an enigma2 box. No need of an DVB-S card anymore. :)
| WinXP SP3 or Win10 1709 | i5 660@3.33Ghz | 4 Gb RAM | ATI Radeon HD 5450 1Gb|
| TT S2-3200 | TT 1501| Astrometa| TT Infrared Receiver| Octagon SF4008 for streaming to ProgDVB|
| Prog demux |
| VMR7 | CyberlinK video decoder (MPEG2) and FFDShow for H264 - DXVA enabled |
| ProgAR | FFDShow audio | Audio processor enabled |
| Timeshift in RAM | Buffer size 2000 |

Re: Streaming from OpenWebIf to ProgDVB

#5
According with what you have seen in the logs some months back is not SAT>IP ( your post is here: viewtopic.php?p=70291#p70291 ) but nevertheless it was not working. Now it started working.
The only renaming issue now is the EPG which is wrongly picked up from the other channels on the same transponder.
| WinXP SP3 or Win10 1709 | i5 660@3.33Ghz | 4 Gb RAM | ATI Radeon HD 5450 1Gb|
| TT S2-3200 | TT 1501| Astrometa| TT Infrared Receiver| Octagon SF4008 for streaming to ProgDVB|
| Prog demux |
| VMR7 | CyberlinK video decoder (MPEG2) and FFDShow for H264 - DXVA enabled |
| ProgAR | FFDShow audio | Audio processor enabled |
| Timeshift in RAM | Buffer size 2000 |

Re: Streaming from OpenWebIf to ProgDVB

#7
Your advice did the trick. Now it works fine. Thanks.

Two other questions:
1. Is ProgDVB still supposed the work on Windows XP? I always get a render error (but it works after pressing Close to that message). This message appears no matter what render I select.
2. There is any trick to make ProgDVB window stick to the screen edges and not leave a space? On older versions it worked well but on this last one always leaves a space to the edge of the screen no matter what I try (is not the only program that does this unfortunately... just that it used to work fine on older versions).
| WinXP SP3 or Win10 1709 | i5 660@3.33Ghz | 4 Gb RAM | ATI Radeon HD 5450 1Gb|
| TT S2-3200 | TT 1501| Astrometa| TT Infrared Receiver| Octagon SF4008 for streaming to ProgDVB|
| Prog demux |
| VMR7 | CyberlinK video decoder (MPEG2) and FFDShow for H264 - DXVA enabled |
| ProgAR | FFDShow audio | Audio processor enabled |
| Timeshift in RAM | Buffer size 2000 |

Re: Streaming from OpenWebIf to ProgDVB

#8
Problem on the XP is solved. Selected another codec (ffdshow) and with this one it works fine.
| WinXP SP3 or Win10 1709 | i5 660@3.33Ghz | 4 Gb RAM | ATI Radeon HD 5450 1Gb|
| TT S2-3200 | TT 1501| Astrometa| TT Infrared Receiver| Octagon SF4008 for streaming to ProgDVB|
| Prog demux |
| VMR7 | CyberlinK video decoder (MPEG2) and FFDShow for H264 - DXVA enabled |
| ProgAR | FFDShow audio | Audio processor enabled |
| Timeshift in RAM | Buffer size 2000 |

Re: Streaming from OpenWebIf to ProgDVB

#10
I only use LAV for H265... for MPEG2 I use the Cyberlink codecs that came with the TT cards while for H264 I use ffdshow. These work best for me and provide the best image quality and the lowest CPU usage.
| WinXP SP3 or Win10 1709 | i5 660@3.33Ghz | 4 Gb RAM | ATI Radeon HD 5450 1Gb|
| TT S2-3200 | TT 1501| Astrometa| TT Infrared Receiver| Octagon SF4008 for streaming to ProgDVB|
| Prog demux |
| VMR7 | CyberlinK video decoder (MPEG2) and FFDShow for H264 - DXVA enabled |
| ProgAR | FFDShow audio | Audio processor enabled |
| Timeshift in RAM | Buffer size 2000 |

Re: Streaming from OpenWebIf to ProgDVB

#11
Problem no2 is no solved also after I have noted that now ProgDVB has a new option "Snap to desktop borders". As soon as this is disabled the gaps to the edge of the desktop are gone on Windows 10. But this is a Windows 10 bug not a ProgDVB bug... a lot of other applications have the same issue.

I have posted just in case it helps others.
| WinXP SP3 or Win10 1709 | i5 660@3.33Ghz | 4 Gb RAM | ATI Radeon HD 5450 1Gb|
| TT S2-3200 | TT 1501| Astrometa| TT Infrared Receiver| Octagon SF4008 for streaming to ProgDVB|
| Prog demux |
| VMR7 | CyberlinK video decoder (MPEG2) and FFDShow for H264 - DXVA enabled |
| ProgAR | FFDShow audio | Audio processor enabled |
| Timeshift in RAM | Buffer size 2000 |
cron