Time Shift Buffer Overfill error !!

#1
Hello,

When i shedule record, often i get the message "time shift buffer overfill" error !?

This happends only when recording channels , not watching live!
Image
Iam using ProgDVBnet 7.25.05


thanks in advance,
TD
Current Main System:
MOBO: Sabretooth FX990 R2.0
CPU: FX-8350BE@4,7Ghz
Cooling: NZXT x52
GPU: RX580 8GB
SSD: Samsung EVO 850 250GB
RAM: 16GB PC3-12800 Quad Channel
Monitor: MSI Optix G27C2
OS: Windows 10 x64 Pro

Re: Time Shift Buffer Overfill error !!

#3
Prog wrote:
Tue Oct 23, 2018 6:21 am
Check you disk or try record to other disk.
Hello,

It has nothing to do with the hdd (SSD in my case). The Drive is a samsung 850 evo and still in pristine condition according to magic software from samsung.

It seems i have solved te problem by enable Timeshift again and beef up buffer from 20 mb to 500MB using Memory (since i have quite some DDR3/ram)
Odd thing is, i get an time shift error although i disable it entirely ? Why is that !?

I disabled Timeshift record because i didn't want to stress out DVbprog/SSD/hdd to much to get it as stable as possible !!

Is dvbprog using / need the timeshift technique for recording regardless of the timeshift settings somehow ?

Anyway, so far i dont have this issue/errors anymore atm..

But now, i have still one thing i gotta deal with !!

When i shedule an 2 records at an later time, only 1 completes the other stream is cut off ? For example both records do overlap eachother at a certain time, and both streams are sheduled to record 1 hour. NOw, 1 file recorded only 1 min while another has the full hour recorded !?

The odd thing is, when iam in front of my pc to test it , and i shedule 2 records to start record after 1 or 2 min everything works ok !!

So, it seems it has nothing to do with the duration of simultanously records i gather !!

But as soon i shedule it for it to record hours later i get incomplete records !???

Logs of the 2 records i speak of are in a attachement ,

Thank you knind for ur support,

regards,
td

EDIT: i forgot to mention this.. When i shedule 2 records to record pretty much simultaneously .. 1 record from channel X lets say and 1 record from channel Y , sometimes dvbprog does both recordings from same channel X for example and not X and other record from Y ?
Current Main System:
MOBO: Sabretooth FX990 R2.0
CPU: FX-8350BE@4,7Ghz
Cooling: NZXT x52
GPU: RX580 8GB
SSD: Samsung EVO 850 250GB
RAM: 16GB PC3-12800 Quad Channel
Monitor: MSI Optix G27C2
OS: Windows 10 x64 Pro
Attachments
Logs.7z
(94.05 KiB) Downloaded 82 times

Re: Time Shift Buffer Overfill error !!

#4
I want to report that there are still an insane amount of "timeshift" errors during recording !!
Using latest build of prognetTV x64, but it happends while using dvbprog x86 (32bit) aswell
Image

SSD did had sufficient space and is in pristine condition while this happends allot !!

I hope this get fixed soon, or a workarround woud be nice ..

regards,
michel,
Current Main System:
MOBO: Sabretooth FX990 R2.0
CPU: FX-8350BE@4,7Ghz
Cooling: NZXT x52
GPU: RX580 8GB
SSD: Samsung EVO 850 250GB
RAM: 16GB PC3-12800 Quad Channel
Monitor: MSI Optix G27C2
OS: Windows 10 x64 Pro

Re: Time Shift Buffer Overfill error !!

#6
Prog wrote:
Fri Nov 16, 2018 6:49 am
Send me logs. Usually that mean too slow HDD for timeshift and record in same time. But SSD is fast device...

I am pretty much sure an SSD should be more than capable for recording usage!? My SSD is an Samsung EVO 850 / 250GB. Just maybe its too fast perhaps for this purpose!? Could that be the reason of timeshift errors ? Maybe some feautures that is typical to SSD drives is causing this ?

But then again, Timeshift errors happends on other mechanical HDD's aswell! And even though while timeshift feature is disabled (entirely!?) in dvbprog , i still get these errors !? How is that possible ?

Could an unstable IPTV provider causing this ? I mean, could this happend because of bad connection/buffer mids program recording ? And the reason of corrupt/messed up time index from recording stream/file ? i mean some streams that are recording for over an hour, do only have an recordtime of several seconds when play back those files ?


Anyway, again i have posted some logs regarding this issue.


regards,
mick
Current Main System:
MOBO: Sabretooth FX990 R2.0
CPU: FX-8350BE@4,7Ghz
Cooling: NZXT x52
GPU: RX580 8GB
SSD: Samsung EVO 850 250GB
RAM: 16GB PC3-12800 Quad Channel
Monitor: MSI Optix G27C2
OS: Windows 10 x64 Pro
Attachments
Logs.7z
(158.4 KiB) Downloaded 58 times

Re: Time Shift Buffer Overfill error !!

#8
Prog wrote:
Sun Nov 18, 2018 8:23 am
No. Your ssd in 100 times more faster then need for record. Looks like problem in ProgDVB. But please add logs2=1 to ProgDVB.ini file for more detailed log

[Debug]
log2=1


You can try chkdsk for check SSD or use other demux (first page of options).
so, i have done what you have suggested. And added the lines "log2=1" to the debug section in the config file from progdvb.ini.

Also, i ran an extended chkdsk on that partition i use for recording. And have found no significant problems like bad sectors, read/write errors and such . And i opted for a cleanup cycle through chkdsk also for that partition.

Iam currious how recordings wil progress from here on!!

I just like to know and ask if it woud help recordings when i enable Timeshift feature ? If so, should i used and enable "use timeshift for recording" aswell ?

Thank you in advance,

regards,
michel
Current Main System:
MOBO: Sabretooth FX990 R2.0
CPU: FX-8350BE@4,7Ghz
Cooling: NZXT x52
GPU: RX580 8GB
SSD: Samsung EVO 850 250GB
RAM: 16GB PC3-12800 Quad Channel
Monitor: MSI Optix G27C2
OS: Windows 10 x64 Pro

Re: Time Shift Buffer Overfill error !!

#10
Prog wrote:
Sun Nov 18, 2018 3:42 pm
log2=1 is for addition data in logs. I am not recommend use this option every day.

What is"use timeshift for recording"?
Timeshift is good in recording time. Timeshift in memory better because not defrag HDD and not use resources of SDD.
I got it, i will use log2 line for logging the timeshift errors, post the logs and reset logging to normal usage again afterwards.

By "use timeshift for recording" i mean, in dvbprog you have the option to enable "using Timeshift mode during record / Async mode" under Record tab.

I have told you that some files that have recorded hours only play for a few seconds and then stop suddenly! And i like to know if that option "timeshift during record" would produce stable and better records?

In the meanwhile i have had the infamous "timeshift errors" again , but this time i have the detailed logs you have asked.
Since the file is too big / detailed to put it in attachement from this post. I have added an link for download ↓.

http://www.mediafire.com/file/d2zf39lff ... gs.7z/file


regards,
michel,
Current Main System:
MOBO: Sabretooth FX990 R2.0
CPU: FX-8350BE@4,7Ghz
Cooling: NZXT x52
GPU: RX580 8GB
SSD: Samsung EVO 850 250GB
RAM: 16GB PC3-12800 Quad Channel
Monitor: MSI Optix G27C2
OS: Windows 10 x64 Pro

Re: Time Shift Buffer Overfill error !!

#11
@progdvb,

I still get Timeshift errors popping up all over the place to the point that the recording application rev 7.26.01 network edition doesn't respond anymore and i have to end the process through taskmanager !!
I have posted numerous times some logs, so if there is any setting i can try to work arround this i would be more than happy to try.

regards,
TD
Current Main System:
MOBO: Sabretooth FX990 R2.0
CPU: FX-8350BE@4,7Ghz
Cooling: NZXT x52
GPU: RX580 8GB
SSD: Samsung EVO 850 250GB
RAM: 16GB PC3-12800 Quad Channel
Monitor: MSI Optix G27C2
OS: Windows 10 x64 Pro

Re: Time Shift Buffer Overfill error !!

#13
Prog wrote:
Wed Dec 19, 2018 1:55 pm
Do you try normal size of timeshift? in log only 40mbyte. I am recommend >=200.
Hello progdvb,

No, i'have the memory set at arround 200MB, thats the first thing i checked every update!
How can it be that the logs tell you different !?

But then again, iam using progdvb for recording while timeshift feature is disabled ! Yet, i keep getting the erros ?!? Why? Also, is that why the logs tell you that the memory is set at 40mb whereas it should be arround 200 like i have settup back when i enabled and used timeshift feature !?

Is it possible the logs registrates only 40MB because i disable timeshift feature!?

I have tried some of the suggestions i read here onsite and encreased it from 40 to 200 to even 500MB using RAM instead of file!!
Granted, the timeshift errors dont ocure so much anymore since a couple revisions ago, but when it does it slowsdown progdvb so much that the app doesnt respond anymore !!

Do you suggest i keep using system memory instead of page file in progdvb for timeshift feature? Or should i try and use file swap method in progdvb ?
Anyway, my win10 system has 16GB DDR3-1866mhz. so i like to think using the system memory is more stable than swap file !

Maybe it has something to do with my new iptv provider (gofastiptv) , loading the channels list (M3u) and browsing through them afterwards goes very slowly in progdvb aswell !!
Maybe its related to my new iptv provider, just wild guessing here !



Thanks for the suggestion,

regards,
TD
Current Main System:
MOBO: Sabretooth FX990 R2.0
CPU: FX-8350BE@4,7Ghz
Cooling: NZXT x52
GPU: RX580 8GB
SSD: Samsung EVO 850 250GB
RAM: 16GB PC3-12800 Quad Channel
Monitor: MSI Optix G27C2
OS: Windows 10 x64 Pro

Re: Time Shift Buffer Overfill error !!

#14
@prog

Today i got an shitstorm of "timeshift errors" up to a point my laptop just didn't respond any more and i had to destroy the process !!
Fyi, the laptop also has an fast SSD for storage.

I don't expect any fix/update soon, but please can you tell me what could be causing this !!!

also and important, is there an command line i can add to the config file to surpress these warnings !!

I await your answer,


ps: i have attached logs once again!


thanks in advance,
td
Current Main System:
MOBO: Sabretooth FX990 R2.0
CPU: FX-8350BE@4,7Ghz
Cooling: NZXT x52
GPU: RX580 8GB
SSD: Samsung EVO 850 250GB
RAM: 16GB PC3-12800 Quad Channel
Monitor: MSI Optix G27C2
OS: Windows 10 x64 Pro
Attachments
Logs.rar
(268.08 KiB) Downloaded 28 times