Page 5 of 8

Re: Открытие канала с первого раза

Posted: Mon Sep 10, 2012 10:59 am
by Prog
Так. хочу этот глюк у себя повторить. На каких каналах он есть? От канала сильно зависит?
От кодеков демуксов судя по логу не зависит, проблема в моём парсере который считает звук aac.

Re: Открытие канала с первого раза

Posted: Mon Sep 10, 2012 11:07 am
by Valera
Prog wrote:Так. хочу этот глюк у себя повторить. На каких каналах он есть? От канала сильно зависит?
От кодеков демуксов судя по логу не зависит, проблема в моём парсере который считает звук aac.
от канала не зависит, на любом может не завестись, демукс майкрософт, evr, video codec - cyberlink 12 оба, звук ffdshow -mpeg, ac-3, aac

Re: Открытие канала с первого раза

Posted: Mon Sep 10, 2012 6:15 pm
by Prog
(g) пререлиз. Хотя я по прежнему уверен что и (f) должен был работать :)

Re: Открытие канала с первого раза

Posted: Mon Sep 10, 2012 6:26 pm
by Valera
Prog wrote:(g) пререлиз. Хотя я по прежнему уверен что и (f) должен был работать :)
чуть лучше чем f но хуже чем d

Re: Открытие канала с первого раза

Posted: Mon Sep 10, 2012 6:59 pm
by Prog
Посмотрите пожалуйста ещё (h)

Re: Открытие канала с первого раза

Posted: Mon Sep 10, 2012 7:01 pm
by Prog
Интересно что судя по логу первые пара ключей были не рабочими и шёл мусор который как раз поломал определение типа.
С другим плагином есть такие проблемы? Сдаётся мне перво причина именно в этом.

Re: Открытие канала с первого раза

Posted: Mon Sep 10, 2012 10:54 pm
by boss911
А у меня проблема была только на определенных каналах, два из них я вам выкладывал.

Re: Открытие канала с первого раза

Posted: Tue Sep 11, 2012 3:20 am
by V.Zhukoff
boss911 wrote:А у меня проблема была только на определенных каналах, два из них я вам выкладывал.
У меня пара каналов вообще отказывается показывать на последних версиях. На старых все отлично. Вот логи для сравнения.
Нормально8402d.rar
(9.96 KiB) Downloaded 182 times
малевич8703f.rar
(5.97 KiB) Downloaded 194 times
Причем поток идет, потерь нет, замок открыт, в логе плагина все отлично. Просто нет картинки и все.

Re: Открытие канала с первого раза

Posted: Tue Sep 11, 2012 3:47 am
by Alexei
У меня на 6.87.х версиях на ABS 1 частота 12518 кодированные каналы тоже сыпятся каждые несколько сек.

Re: Открытие канала с первого раза

Posted: Tue Sep 11, 2012 4:13 am
by Valera
Prog wrote:Посмотрите пожалуйста ещё (h)
вроде стало нормально, 100 переключений - ни одного глюка, но еще потестирую

Re: Открытие канала с первого раза

Posted: Tue Sep 11, 2012 4:45 am
by V.Zhukoff
В h у меня этот канал тоже открылся

Re: Открытие канала с первого раза

Posted: Tue Sep 11, 2012 5:39 am
by Prog
Теперь вместо этого глюка будет задержка на 5 секунд перед открытием канала. потому что судя по старым логам, первая пара ключей от плагина - не рабочие. 90% что на стороне плагина, 10% что у меня. Сложно проверить.

Re: Открытие канала с первого раза

Posted: Tue Sep 11, 2012 5:40 am
by Prog
Alexei wrote:У меня на 6.87.х версиях на ABS 1 частота 12518 кодированные каналы тоже сыпятся каждые несколько сек.
В какой последней не сыпались?

Re: Открытие канала с первого раза

Posted: Tue Sep 11, 2012 5:50 am
by V.Zhukoff
Prog wrote:Теперь вместо этого глюка будет задержка на 5 секунд перед открытием канала. потому что судя по старым логам, первая пара ключей от плагина - не рабочие.
Как же не рабочие? Я же пишу-в логе плагина идет нужный идент, Я еще раз принудительно указываю ему его- нет картинки. В самом плагине есть файл chcache.ini где хранятся нужные иденты.
Prog wrote:90% что на стороне плагина, 10% что у меня. Сложно проверить.
На мой взгляд, расклад другой чуток. 0%-100% :) . Вы упорно игнорируете тот факт, что тот же плагин и тот же канал ведут себя по-разному в двух версиях. Я и логи выложил.
Поэтому, ваше решение глюка за счет времени переключения канала никуда не годится.

Re: Открытие канала с первого раза

Posted: Tue Sep 11, 2012 5:54 am
by Prog
А это не моё решение. Сама проблема возникла что после первых ключей ProgDVB 5 секунд огребает мусор вместо трафика, без него проблемы не было ни в одной из версий.
Этот первый периуд сейчас хорошо видно в логе. Ключи прошли, но но не видео ни аудио найти не получается. И только после вторых начинает работать.
От версии это зависит только в плане реакции на первую порцию мусора, и лога.