не показывает часть каналов (IPTV)

#1
Добрый день!
Я использую ProgDVB для просмотра IPTV. У меня почему то на некоторых каналах ничего не показывает, хотя поток (небольшой) явно идет - судя по столбикам в статусной строке и меняющимся цифрам 189-212kB/s. Такое наблюдается на всех HD каналах, и на некоторых обычных. При этом VLC эти же каналы показывает без проблем.
Помогите, пожалуйста. Если нужны логи или другая информация - предоставлю.

Re: не показывает часть каналов (IPTV)

#3
Записал поток с обычного (SD) канала, т.к. HD получался > 2Мб, скрутил логи - не знаю, все ли правильно сделал...
Писал самим ProgDVB. При записи в ProgDVB картинки и звука не было (черный экран), но если полученный TS открыть в KMPlayer - все показывает.

upd: кстати, не знаю, окажется ли эта информация полезной, но я заметил, что у всех неработающих каналов есть общая черта - у них у всех PID Video = 10 (во всяком случае у всех, которые я проверял)
Attachments
Record.rar
(1.44 MiB) Downloaded 506 times
Logs.rar
(20.67 KiB) Downloaded 464 times

Re: не показывает часть каналов (IPTV)

#4
Ого! А на самом деле он какой? Подсмотрите значение в какомнибуть посторонем плеере. Пример конечно слишком короткий, нужен минут 3-5.
Значение 10 - это конечно причина не работы. Оно просто не по стандарту и ProgDVB не покажет. Нужен пример на любом удобном хосте.

Re: не показывает часть каналов (IPTV)

#5
Вот, сделал запись потока продолжительностью 4 мин 10 сек: http://filestore.com.ua/?d=89254AAB9
По поводу истинного значения PID потока - я смотрел в VLC, и он тоже показывает 10 (или может я не там смотрел).
Вот скриншот:
Image
Хотелось бы, чтобы ваша программа тоже показывала эти каналы, хоть они и не по стандарту... :roll:
cron