Re: авто-обновление BETA версий

#3
Prog wrote:
Thu Jul 19, 2018 3:59 pm
Начиная с 2.57.0 BETA должны обновляться на всех версиях Android.
У кого не так - описывайте симптомы.
Отписываю симптомы:
Версия 2.79.2 не обновляется до следующей сборки ни автоматически - файлом обновления, ни файлом установщиком поверх версии 2.79.2. Выдает синтаксическую ошибку. Однако, как новая установка 2.79.3 поставилась. Хорошо, что есть заранее подготовленный файл настроек.
Надо отметить, что файлом обновления ни разу не удавалось обновить ни одну версию, как Beta. так и релиз. Выдается ошибка.
Приходилось ставить поверх старой версии, но теперь и так не обновить.
Last edited by Emin on Thu Jul 25, 2019 1:05 pm, edited 1 time in total.

Re: авто-обновление BETA версий

#5
Prog wrote:
Thu Jul 25, 2019 6:23 am
Быо глюк в манифесте .3 версии. Сейчас обновлю
Обновление до 2.79.4 теперь выполняется. Не знаю в чем казус, но дело обстоит так:
На смартфоне с Android 6.0 всё проходит в автомате из-под приложения, а на IPTV Android 8.1 в автомате выдает "Ошибка при синтаксическом анализе пакета" и обновление отменяется. Поверх остановленного приложения на IPTV стало обновляться.
Ни тот, ни другой не рутирован. Ну хоть так.

Re: авто-обновление BETA версий

#7
Prog wrote:
Mon Jul 29, 2019 1:47 pm
в .3 был просто косяк в манифесте, который я на следующий день исправил не меняя номер версии. От версии андройд это не зависит
Я тоже так иногда делаю, если сборка с обнаруженной ошибкой совсем мало пролежала на загрузке. Всё равно следующее обновление будет с новым индексом.
cron